xref: /aoo41x/main/package/util/makefile.mk (revision cdf0e10c)
1#*************************************************************************
2#
3# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
4#
5# Copyright 2000, 2010 Oracle and/or its affiliates.
6#
7# OpenOffice.org - a multi-platform office productivity suite
8#
9# This file is part of OpenOffice.org.
10#
11# OpenOffice.org is free software: you can redistribute it and/or modify
12# it under the terms of the GNU Lesser General Public License version 3
13# only, as published by the Free Software Foundation.
14#
15# OpenOffice.org is distributed in the hope that it will be useful,
16# but WITHOUT ANY WARRANTY; without even the implied warranty of
17# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
18# GNU Lesser General Public License version 3 for more details
19# (a copy is included in the LICENSE file that accompanied this code).
20#
21# You should have received a copy of the GNU Lesser General Public License
22# version 3 along with OpenOffice.org.  If not, see
23# <http://www.openoffice.org/license.html>
24# for a copy of the LGPLv3 License.
25#
26#*************************************************************************
27
28# 2 == Unicode
29MAJOR_VERSION=2
30
31PRJ=..
32PRJNAME=package
33TARGET=package
34
35ENABLE_EXCEPTIONS=TRUE
36USE_DEFFILE=TRUE
37NO_BSYMBOLIC=TRUE
38
39
40# --- Settings -----------------------------------------------------
41
42.INCLUDE :  settings.mk
43
44.IF "$(L10N_framework)"==""
45
46# --- General ----------------------------------------------------
47
48LIB1TARGET= $(SLB)$/$(TARGET).lib
49LIB1FILES=	\
50    $(SLB)$/zipapi.lib \
51    $(SLB)$/zippackage.lib \
52    $(SLB)$/manifest.lib
53
54# --- Shared-Library -----------------------------------------------
55
56SHL1TARGET=$(TARGET)$(MAJOR_VERSION)
57SHL1IMPLIB=i$(TARGET)
58SHL1VERSIONMAP=$(SOLARENV)$/src$/component.map
59
60SHL1STDLIBS=\
61	$(CPPULIB)		\
62	$(UCBHELPERLIB)		\
63	$(CPPUHELPERLIB)	\
64	$(COMPHELPERLIB)		\
65	$(SALLIB)		\
66	$(ZLIB3RDLIB)
67
68SHL1DEF=$(MISC)$/$(SHL1TARGET).def
69SHL1LIBS=$(LIB1TARGET)
70DEF1NAME=$(SHL1TARGET)
71
72.ENDIF # L10N_framework
73
74# --- Targets ----------------------------------------------------------
75
76.INCLUDE :  target.mk
77
78
79ALLTAR : $(MISC)/package2.component
80
81$(MISC)/package2.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
82        package2.component
83    $(XSLTPROC) --nonet --stringparam uri \
84        '$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL1TARGETN:f)' -o $@ \
85        $(SOLARENV)/bin/createcomponent.xslt package2.component
86